Rank 2: Process
That's also what I think 🙂 I've got the same yesterday and I removed an URL attrib (2000 chars) that solved my problem, even if I was far from reaching the limit.
Votes
0
Replies
24
Participants
Unknown
Messages
25
Rank 2: Process
That's also what I think 🙂 I've got the same yesterday and I removed an URL attrib (2000 chars) that solved my problem, even if I was far from reaching the limit.
Rank 2: Process
Not sure if it's related but I'm heavily playing with the creation/deletion of attribs by scripting.
Rank 2: Process
Weird as it's a MariaDB error and looking at the tables with Navicat doesn't show any big fields...
Admin
Did this error happen when you had the url attribute?
Rank 2: Process
No when I tried to add a new 10chars attribute. Even an Integer one failed until I successfully removed the URL.
Rank 2: Process
And also, adding some indexes display "failed" even if it works! Not sure if this is related.
Admin
"works" because the query works?
Admin
And now adding a attribute still fails?
Rank 2: Process
In fact I thought my indexes were created but it really doesn't work, except sometimes for some
Rank 2: Process
I delete my collection but I can try again
Admin
The url attribute could have been the problem. I don't think I can reproduce with the list you gave me if that wasn't the list of attributes you had when you were experiencing the problem.
If you can reproduce the problem, feel free to create an issue with the exact steps
Admin
Sorry can you clarify what you mean?
Rank 2: Process
Thanks, I will try to reproduce it.
Regarding the indexes, I thought the "failed" ones were really created but they don't show on the DB (in my Navicat MySQL client) so it really fails. Will try to reproduce too!
Thanks for your help.
Rank 2: Process
BTW, does the indexes need a unique key database-wide or only in their collection? Because I fail to create an index named index_4 (no other index with this key in the collection) but I can with index_44 (with same attribs and options)
Admin
Failed means the index wasn't created
Rank 2: Process
Yes, this time I checked on Navicat. The logs show appwrite-worker-databases | Index already exists
Admin
So there are 2 places. If you see the index in the Appwrite Console, theres an index metadata. Then, there's the actual index created in the database
Rank 2: Process
index_4 shows a failed tag, then I remove it (in Web Console), then I recreate it as index_44, it works, delete it again and retry as index_4 -> failed again.
Admin
And the database worker logs say index already exists?
Rank 2: Process
Yes it does
Admin
Weird...I wonder if there's a ghost index or something...
@Gildas Quiniou Chiming in on this. Was this project migrated from earlier Appwrite versions?
Trying to see if this could be related to migration. While this doesn't help you solve your issue... would definitely help with us narrowing down the problem
Rank 2: Process
Hi, no it is not a migration. I also recreated a brand new database from the latest (1.2) release. The only thing is I'm heavily playing with creating and deleting attributes and indexes with the API (scripted), not the Web console. I've a script that deals with reordering the attribs for which I clone attribs using temporary names to be able to finally recreate them in the expected order. Doing so I may stress the create/delete attribs API a little bit as I also need to loop until the actions go from "processing" to "available", could this be a reason?
Admin
hmm...if you can reproduce it reliably, you can share the steps so that we could troublesohot too